PPPoE(動的払い出しの場合)

Point to Point Protocol over Ethernet

構成

PPPoE部分のみ

設定 client

PPPoE-cl(config)#interface Dialer1
PPPoE-cl(config-if)#ip address negotiated
PPPoE-cl(config-if)#ip mtu 1454
PPPoE-cl(config-if)#encapsulation ppp
PPPoE-cl(config-if)#dialer pool 1
PPPoE-cl(config-if)#dialer-group 1
PPPoE-cl(config-if)#ppp authentication chap callin
PPPoE-cl(config-if)#ppp chap hostname TEST
PPPoE-cl(config-if)#ppp chap password PASS

PPPoE-cl(config)#dialer-list 1 protocol ip permit

PPPoE-cl(config)#interface GigabitEthernet1/0
PPPoE-cl(config-if)#pppoe enable group global
PPPoE-cl(config-if)#pppoe-client dial-pool-number 1
PPPoE-cl(config-if)#no shutdown

PPPoE-cl(config-if)#ip route 0.0.0.0 0.0.0.0 dialer1

dns-svアドレス自動取得
ppp ipcp dns request accept
BAS向けデフォルトルート自動設定
ppp ipcp route default

設定 server

PPPoE-sv(config)#username TEST password PASS

PPPoE-sv(config)#bba-group pppoe TEST-GROUP
PPPoE-sv(config-bba-group)#virtual-template 1

PPPoE-sv(config)#interface GigabitEthernet 1/0
PPPoE-sv(config-if)#pppoe enable group global
PPPoE-sv(config-if)#no shutdown

PPPoE-sv(config)#ip local pool WAN 123.1.1.129 123.1.1.254

PPPoE-sv(config)#interface Virtual-Template1
PPPoE-sv(config-if)#mtu 1454
PPPoE-sv(config-if)#ip unnumbered Loopback0
PPPoE-sv(config-if)#peer default ip address pool WAN
PPPoE-sv(config-if)#ppp authentication chap pap

PPPoE-sv(config-if)#int lo0
PPPoE-sv(config-if)#ip add 123.1.1.20 255.255.255.255

確認

■PPPoE-cl

sh pppoe session ,all
clientからserverへping

■PPPoE-sv

PPPoEとしては完了。これだけではconnectedの通信しかできないので、NATとISP側のルーティングが必要。別記事にて。